Core Java

Facebook Hacker Cup : Studious Student Problem Solution in Java

This program is a solution to Studious Student problem from Facebook Hacker Cup. The problem can be found here: link.

The problem:

Studious Student

You’ve been given a list of words to study and memorize. Being a diligent student of language and the arts, you’ve decided to not study them at all and instead make up pointless games based on them. One game you’ve come up with is to see how you can concatenate the words to generate the lexicographically lowest possible string.

Input

As input for playing this game you will receive a text file containing an integer N, the number of word sets you need to play your game against. This will be followed by N word sets, each starting with an integer M, the number of words in the set, followed by M words. All tokens in the input will be separated by some whitespace and, aside from N and M, will consist entirely of lowercase letters.

Output

Your submission should contain the lexicographically shortest strings for each corresponding word set, one per line and in order.

Constraints

1
2
3
1 <= N <= 100
1 <= M <= 9
1 <= all word lengths <= 10

Example input

1
2
3
4
5
6
5
6 facebook hacker cup for studious students
5 k duz q rc lvraw
5 mybea zdr yubx xe dyroiy
5 jibw ji jp bw jibw
5 uiuy hopji li j dcyi

Example output

1
2
3
4
5
cupfacebookforhackerstudentsstudious
duzklvrawqrc
dyroiymybeaxeyubxzdr
bwjibwjibwjijp
dcyihopjijliuiuy
01
02
03
04
05
06
07
08
09
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
import java.io.*;
import java.util.Arrays;
public class StudiousStudent
{
    StudiousStudent(String inputFile) throws IOException, FileNotFoundException
    {
        FileInputStream fis = new FileInputStream(inputFile);
        DataInputStream in = new DataInputStream(fis);
        BufferedReader br = new BufferedReader(new InputStreamReader(in));
        String line = null;
        String splitArray[] = null;
        //Reading the file line by line
        while((line = br.readLine()) != null)
        {
            //Splitting a line from spaces
            splitArray = line.split(" ");
 
            //Initial Sort
            Arrays.sort(splitArray);
 
            //Advanced Sort
            for (int i = 1; i<splitArray.length; i++)
            {
                for (int j = i+1; j<splitArray.length; j++)
                {
                    if ((splitArray[j].startsWith(splitArray[i])) && (splitArray[i].length() < splitArray[j].length()))
                    {
                        String tmp = splitArray[i];
                        splitArray[i] = splitArray[j];
                        splitArray[j] = tmp;
                    }
                }
            }
            for (int i = 1; i<splitArray.length; i++) System.out.print(splitArray[i]+"");
            System.out.println();
        }
        br.close();
    }
    public static void main(String args[]) throws FileNotFoundException, IOException
    {
        new StudiousStudent("StudiousStudent.txt");
    }
}

Output:
Output for Studious Student

 

Reference: Facebook Hacker Cup : “Studious Student” Solution in Java from our JCG partner Vishal Lad at the myCoding.net blog.

Do you want to know how to develop your skillset to become a Java Rockstar?
Subscribe to our newsletter to start Rocking right now!
To get you started we give you our best selling eBooks for FREE!
1. JPA Mini Book
2. JVM Troubleshooting Guide
3. JUnit Tutorial for Unit Testing
4. Java Annotations Tutorial
5. Java Interview Questions
6. Spring Interview Questions
7. Android UI Design
and many more ....
I agree to the Terms and Privacy Policy
Subscribe
Notify of
guest


This site uses Akismet to reduce spam. Learn how your comment data is processed.

2 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Bryan Murphy
Bryan Murphy
12 years ago

Scala solution (without validation):

Source.fromFile(“StudiousStudent.txt”).getLines.toList.tail.map(_.trim.split(“\s+”).toList).map(_.tail.sorted.mkString)

Djo Ziani
Djo Ziani
11 years ago

hola

Back to top button